Absolute, relatieve en gemengde adressering

Absolute, relatieve en gemengde adressering

Wanneer je een formule ingeeft en doorvoert via de vulgreep is het belangrijk om te weten of je een absolute of relatieve doorvoering wenst. Om goed te begrijpen wat het verschil is tussen beide krijg je hieronder een korte uitleg over beide adresseringen.

1      Relatieve adressering


 

Een relatieve adressering is een verwijzing naar een cel die tijdens het kopiëren (of het gebruiken van de vulgreep) de cellen automatisch zal aanpassen. Standaard is dit zo in Excel ingesteld.

Vb. Je gebruikt de vulgreep om een formule te kopiëren:
=SOM(A2:A5) wordt op de volgende rij automatisch =SOM(B2:B5) en op de volgende =SOM(C2:C5).

OPDRACHT (DEEL 1)

    • Voor deze opdracht werk je in het werkblad ‘Planckendael’.
  •  
    • Bereken in cel G6 het ‘Totaal aantal uren‘ van Cindy Janssens. Gebruik hiervoor de functie ‘Som’ .
    • Gebruik de vulgreep om het ‘Totaal aantal uren‘ voor de andere werknemers te berekenen (cellen G7 tot en met G9).
  •  
    • Bereken in cel H6 het ‘Loon‘ van Cindy Janssens (= totaal aantal uren x uurloon). Wijzig de formule met behulp van dollartekens zodat je bij het uurloon werkt met een absolute celadressering.
  •  
    • Gebruik de vulgreep om het ‘Totaal aantal uren‘ voor de andere werknemers te berekenen (cellen G7 tot en met G9).

Eindresultaat:

2      Absolute adressering

Bij een absolute adressering blijft de cel verwijzing naar dezelfde cel verwijzen. Bv. je moet een vermenigvuldiging doen met een uurloon. Het uurloon zal niet variëren, wel het aantal uren per dag of per week. Je zal dus voor het uurloon een absolute adressering gebruiken.

Vb. Je gebruikt de vulgreep om de formule door te trekken maar je gaat 1 cel vastleggen door de $ teken te gebruiken.
=SOM(A2:$A$1) wordt op de volgende rij =SOM(B2:$A$1) en op de volgende rij =SOM(C2:$A$1)

3      Gemengde adressering

 

Je zal merken dat je vaker gebruik zal maken van gemengde verwijzingen, dan van zuiver absolute verwijzingen. Een gemengde verwijzing fixeert de kolom maar niet de rij, of fixeert de rij maar niet de kolom. Onderstaande formules maken gebruik van gemengde verwijzingen:

=$C1/2

=C$1/2

Stel dat je een formule kopieert die de verwijzing $C1 gebruikt. Ongeacht waar je de formule plaatst, zal deze altijd verwijzen naar kolom C. De verwijzing naar het rijnummer wordt wel aangepast, omdat direct hiervoor geen dollarteken staat.

Op dezelfde manier geldt, dat als je een formule kopieert die de verwijzing C$1 bevat, de kolom zal worden aangepast, maar het rijnummer niet.

OPDRACHT (DEEL 2)

    • Voor deze opdracht werk je in het werkblad ‘Tafels van vermeningvuldiging’.
  •  
    • Kolom A en Rij 2 bevatten de cijfers waarmee je de tafels van vermenigvuldiging kan berekenen.
  •  
    • Het is de bedoeling dat jij met behulp van één formule in de cel B3 en het gebruik van de vulgreep de MS Excel de tafels van vermenigvuldiging laat berekenen!  Je mag dus zelf geen formules typen in de andere cellen!
  •  
    • Vul de juiste formule in in cel B3. Werk met de juiste dollartekens voor de kolomletter of het rijcijfer. Denk goed na over hoe je de dollartekens moet plaatsen. Moet de kolom worden behouden? Plaats daarvoor dan een dollarteken. Moet de rij worden behouden? Plaats daarvoor dan een dollarteken.
  •  
    • Voer met de vulgreep de formule in cel B3 door naar de andere cellen. Kloppen de resultaten niet? Pas dan je formule in de cel B3 aan en probeer opnieuw. 

Eindresultaat: