3 Absolute, relatieve en gemengde adressering

3               Absolute, relatieve en gemengde adressering
3.1            Relatieve adressering
3.2            Absolute adressering
3.3            Gemengde adressering


3       Absolute, relatieve en gemengde adressering

Wanneer je een formule ingeeft en doorvoert via de vulgreep is het belangrijk om te weten of je een absolute of relatieve doorvoering wenst. Om goed te begrijpen wat het verschil is tussen beide krijg je hieronder een korte uitleg over beide adresseringen.

3.1      Relatieve adressering

Een relatieve adressering is een verwijzing naar een cel die tijdens het kopiëren (of het gebruiken van de vulgreep) de cellen automatisch zal aanpassen. Standaard is dit zo in Excel ingesteld.

Vb. Je gebruikt de vulgreep om een formule te kopiëren:
=SOM(A2:A5) wordt op de volgende rij automatisch =SOM(B2:B5) en op de volgende =SOM(C2:C5).

3.2      Absolute adressering

Bij een absolute adressering blijft de cel verwijzing naar dezelfde cel verwijzen. Bv. je moet een vermenigvuldiging doen met een uurloon. Het uurloon zal niet variëren, wel het aantal uren per dag of per week. Je zal dus voor het uurloon een absolute adressering gebruiken.

Vb. Je gebruikt de vulgreep om de formule door te trekken maar je gaat 1 cel vastleggen door de $ teken te gebruiken.
=SOM(A2:$A$1) wordt op de volgende rij =SOM(B2:$A$1) en op de volgende rij =SOM(C2:$A$1)

3.3      Gemengde adressering

Je zal merken dat je vaker gebruik zal maken van gemengde verwijzingen, dan van zuiver absolute verwijzingen. Een gemengde verwijzing fixeert de kolom maar niet de rij, of fixeert de rij maar niet de kolom. Onderstaande formules maken gebruik van gemengde verwijzingen:

=$C1/2

=C$1/2

Stel dat je een formule kopieert die de verwijzing $C1 gebruikt. Ongeacht waar je de formule plaatst, zal deze altijd verwijzen naar kolom C. De verwijzing naar het rijnummer wordt wel aangepast, omdat direct hiervoor geen dollarteken staat.

Op dezelfde manier geldt, dat als je een formule kopieert die de verwijzing C$1 bevat, de kolom zal worden aangepast, maar het rijnummer niet.